GSAK, GARMIN och ÅÄÖ

Diskussioner om programvara för datorer (GSAK, Mapsource och liknande).
Användarvisningsbild
T.N.L.N
Geocachare
Inlägg:119
Blev medlem:tor apr 21, 2005 11:53
GSAK, GARMIN och ÅÄÖ

Inlägg av T.N.L.N » mån apr 27, 2009 21:47

Jag använder en Garmin GPSmap 60CSx och när jag för över waypoints från GSAK så hänger inte ÅÄÖ med. De försvinner helt. Ersätts altså inte av ngt specialtecken eller så. Nån som har en lösning på det? Inte för att det är ngt värdsomvälvande problem, men inget är ju så bra att det inte kan bli bättre.
Användarvisningsbild
Cordin
Föreningsmedlem
Inlägg:592
Blev medlem:tis jan 29, 2008 21:40

Inlägg av Cordin » mån apr 27, 2009 22:14

Kör du med smartname, för då kan det vara ifyllt i options att gsak ska plocka bort å ä ö ur smart name.

Vet inte om det fungerar över huvud taget men om det gör det så kan det vara en lösning...

/Cordin
Bild
***
Var dig själv alla andra är upptagna.
Användarvisningsbild
kallt_kaffe
Geocachare
Inlägg:657
Blev medlem:fre sep 05, 2008 14:40

Inlägg av kallt_kaffe » mån apr 27, 2009 22:24

Det finns en inställning ngnstans i GSAK som heter ngt i stil med "keep chars" där du fyller i å;ä;ö;Å;Ä;Ö
"Isn't it enough to see that a garden is beautiful without having to believe that there are fairies at the bottom of it too?" - Douglas Adams
Användarvisningsbild
T.N.L.N
Geocachare
Inlägg:119
Blev medlem:tor apr 21, 2005 11:53

Inlägg av T.N.L.N » mån apr 27, 2009 22:36

cordin skrev:Kör du med smartname, för då kan det vara ifyllt i options att gsak ska plocka bort å ä ö ur smart name.
/Cordin
Tror att jag kör med det. Har inte vant mig med alla inställningarna än. Måste kolla.
Falkz
Geocachare
Inlägg:954
Blev medlem:sön jan 18, 2009 20:29

Inlägg av Falkz » mån apr 27, 2009 22:36

finns direkt under tools --> options sen nere till höger under general fliken
Användarvisningsbild
T.N.L.N
Geocachare
Inlägg:119
Blev medlem:tor apr 21, 2005 11:53

Inlägg av T.N.L.N » tis apr 28, 2009 11:30

Falkz skrev:finns direkt under tools --> options sen nere till höger under general fliken
Testade det. Fungerar inte. Jag provar nåt annat. BRB
camdan
Geocachare
Inlägg:544
Blev medlem:ons jan 16, 2008 9:45

Inlägg av camdan » tis apr 28, 2009 11:59

kallt_kaffe skrev:Det finns en inställning ngnstans i GSAK som heter ngt i stil med "keep chars" där du fyller i å;ä;ö;Å;Ä;Ö
Jag använder "keep chars" och det funkar så länge Å.Ä,Ö finns mitt inne i cachenamnet, men så fort första bokstaven i cachenamnet är ett "specialtecken" så faller denna bort.

Vad beror detta på?
Användarvisningsbild
kallt_kaffe
Geocachare
Inlägg:657
Blev medlem:fre sep 05, 2008 14:40

Inlägg av kallt_kaffe » tis apr 28, 2009 11:59

T.N.L.N skrev:
Falkz skrev:finns direkt under tools --> options sen nere till höger under general fliken
Testade det. Fungerar inte. Jag provar nåt annat. BRB
Jodå, det ska det visst göra. Funkar klockrent på min HCx och 60CSx bör fungera lika.

Tools->Options->Keep chars. Fyll i:å;ä;ö;Å;Ä;Ö

Såvida vi pratar waypoints och inte POIs. För om du exporterar POIs med 60CSxPOI makrot så försvinner åäö men det går att lösa. Det finns en post i macrots supportforum där jag visar vilken rad i makrot som skall ändras.

EDIT: För att få med svenska tecken med 60CSxPOI makrot: http://gsak.net/board/index.php?showtop ... st&p=73615
Senast redigerad av 1 kallt_kaffe, redigerad totalt 0 gånger.
"Isn't it enough to see that a garden is beautiful without having to believe that there are fairies at the bottom of it too?" - Douglas Adams
Falkz
Geocachare
Inlägg:954
Blev medlem:sön jan 18, 2009 20:29

Inlägg av Falkz » tis apr 28, 2009 12:03

Fungerar för mig oxå på min legend hcx
Användarvisningsbild
T.N.L.N
Geocachare
Inlägg:119
Blev medlem:tor apr 21, 2005 11:53

Inlägg av T.N.L.N » tis apr 28, 2009 12:20

Ja men då borde ju funka för mig med. Jag klickar i menyn på Gps/Skicka waypoints (eller vad det står). Jag använder inget makro. bara de inbygda funktionerna. jag har lagt in åäö med semikolon som avgränsare. Kan det vara ngn inställning i GPSen?
Användarvisningsbild
kallt_kaffe
Geocachare
Inlägg:657
Blev medlem:fre sep 05, 2008 14:40

Inlägg av kallt_kaffe » tis apr 28, 2009 12:25

T.N.L.N skrev:Ja men då borde ju funka för mig med. Jag klickar i menyn på Gps/Skicka waypoints (eller vad det står). Jag använder inget makro. bara de inbygda funktionerna. jag har lagt in åäö med semikolon som avgränsare. Kan det vara ngn inställning i GPSen?
Jag ska dock erkänna att jag bara testat detta på min Legend HCx och på min Nüvi 255. Aldrig på en 60CSx.

Men du... just det... inställningen gäller nog enbart om du använder Smartname när du genererar waypointnamnen. Jag kör med detta till min Nüvi: %Smart=9(%Dif/%Ter/%con1)
Maximum characters har jag satt till 20.

Du kan ev. behöva köra %Dif1a och %Ter1a på CSx:en då, om jag minns rätt, den inte visar decimaltecknet. Det var ett tag sedan jag använd "Send to GPS" till min HCx. Numera använder jag bara makrot och lägger över dem som POIs istället.
"Isn't it enough to see that a garden is beautiful without having to believe that there are fairies at the bottom of it too?" - Douglas Adams
Användarvisningsbild
Str@tocaster
Geocachare
Inlägg:319
Blev medlem:tis nov 25, 2008 14:21

Inlägg av Str@tocaster » tis apr 28, 2009 13:04

camdan skrev:Jag använder "keep chars" och det funkar så länge Å.Ä,Ö finns mitt inne i cachenamnet, men så fort första bokstaven i cachenamnet är ett "specialtecken" så faller denna bort.

Vad beror detta på?
Jag har exakt samma problem och har därför ställt frågan i GSAK-forumet http://gsak.net/board/index.php?showtop ... 5&st=0&hl= utan att egentligen få någon lösning där. Problemet verkar ligga i GPSBabel som skickar data till GPS:en.

I tråden ovan beskrivs en dock workaround som jag använder. Jag tar in GPX-filerna i GSAK och exporterar sedan (med smartname) till en GPX-fil File ->Export ->GPX/LOC file. Den exporterade filen tar jag sedan in i MapSource och därifrån skickar jag den sedan till GPS:en. Omständigt men fungerande.
Bild
Oregon 450T med Friluftskartan Pro (SGSIII och c:geo för spontancaching)
Användarvisningsbild
kallt_kaffe
Geocachare
Inlägg:657
Blev medlem:fre sep 05, 2008 14:40

Inlägg av kallt_kaffe » tis apr 28, 2009 13:18

The Strat skrev:
camdan skrev:Jag använder "keep chars" och det funkar så länge Å.Ä,Ö finns mitt inne i cachenamnet, men så fort första bokstaven i cachenamnet är ett "specialtecken" så faller denna bort.

Vad beror detta på?
Jag har exakt samma problem och har därför ställt frågan i GSAK-forumet http://gsak.net/board/index.php?showtop ... 5&st=0&hl= utan att egentligen få någon lösning där. Problemet verkar ligga i GPSBabel som skickar data till GPS:en.

I tråden ovan beskrivs en dock workaround som jag använder. Jag tar in GPX-filerna i GSAK och exporterar sedan (med smartname) till en GPX-fil File ->Export ->GPX/LOC file. Den exporterade filen tar jag sedan in i MapSource och därifrån skickar jag den sedan till GPS:en. Omständigt men fungerande.
Numera använder jag bara 60CSxPOI makrot (med lite egna modifikationer) och då får jag iaf med svenska tecken på första bokstaven i namnet.

För övrigt rekommenderar jag att använda makrot istället. Dels har du ingen begränsning på hur många cachar du kan lägga in och dels så kan du få med mycket mer info (om du vill). Jag tar med status på senaste fyra loggningarna samt hinten. Att den inte visar POIs förrän en viss zoomnivå går att konfigurera.

För mer info om hur jag använder makrot se denna post: http://forums.groundspeak.com/GC/index. ... &p=3861333

Och för info om vilka förändringar som krävs i makrot för svenska tecken se denna post: http://gsak.net/board/index.php?showtop ... st&p=73615
"Isn't it enough to see that a garden is beautiful without having to believe that there are fairies at the bottom of it too?" - Douglas Adams
Användarvisningsbild
jimnil
Geocachare
Inlägg:26
Blev medlem:sön jul 27, 2008 22:09

Inlägg av jimnil » tis apr 28, 2009 14:14

kallt_kaffe skrev:
T.N.L.N skrev:
Falkz skrev:finns direkt under tools --> options sen nere till höger under general fliken
Testade det. Fungerar inte. Jag provar nåt annat. BRB
Jodå, det ska det visst göra. Funkar klockrent på min HCx och 60CSx bör fungera lika.

Tools->Options->Keep chars. Fyll i:å;ä;ö;Å;Ä;Ö

Såvida vi pratar waypoints och inte POIs. För om du exporterar POIs med 60CSxPOI makrot så försvinner åäö men det går att lösa. Det finns en post i macrots supportforum där jag visar vilken rad i makrot som skall ändras.

EDIT: För att få med svenska tecken med 60CSxPOI makrot: http://gsak.net/board/index.php?showtop ... st&p=73615
Jag tror inte man ska ha ( ; ) mellan bokstäverna, det har inte jag och enligt hjälpen så är det utan.
Användarvisningsbild
Skarek
Geocachare
Inlägg:200
Blev medlem:tis maj 13, 2008 19:40

Inlägg av Skarek » sön maj 03, 2009 11:54

Det mest mystiska med ÅÄÖ-problemet är att det blev löst för mig i en gammal version jag hade. Då funka allt som det skulle. Sen har det återuppstått. GPSBabel, vem gör det? Är de de som har mekat om versionen och fumlat till något.

Min tråd på GSAK:s forum:
http://gsak.net/board/index.php?showtopic=9689

När jag gjorde min post den 12 oktober så fungerade det som det borde med ÅÄÖ som förstatecken till GPS:en. Nu har dock problemet återuppstått.
Bild
Skriv svar