GSAK, GARMIN och ÅÄÖ

Diskussioner om programvara för datorer (GSAK, Mapsource och liknande).
camdan
Geocachare
Inlägg:544
Blev medlem:ons jan 16, 2008 9:45

Inlägg av camdan » tor maj 14, 2009 17:45

The Strat skrev:
camdan skrev:Jag använder "keep chars" och det funkar så länge Å.Ä,Ö finns mitt inne i cachenamnet, men så fort första bokstaven i cachenamnet är ett "specialtecken" så faller denna bort.

Vad beror detta på?
Jag har exakt samma problem och har därför ställt frågan i GSAK-forumet http://gsak.net/board/index.php?showtop ... 5&st=0&hl= utan att egentligen få någon lösning där. Problemet verkar ligga i GPSBabel som skickar data till GPS:en.

I tråden ovan beskrivs en dock workaround som jag använder. Jag tar in GPX-filerna i GSAK och exporterar sedan (med smartname) till en GPX-fil File ->Export ->GPX/LOC file. Den exporterade filen tar jag sedan in i MapSource och därifrån skickar jag den sedan till GPS:en. Omständigt men fungerande.
Jag blir inte klok på detta. Jag installerade GSAK på min nya Vista-dator. Under "Keep chars" skrev jag in EXAKT likadant som på min gamla XP-dator. Det vill säga å;ä;ö;Å;Ä;Ö Detta funkade dock inte alls. Istället skrev åäöÅÄÖ i en enda lång rad utan semikolon. Då funkade det till 100%.

Till och med förstabokstäverna följer med.
Vilket dom inte gör i min gamla XP-installation. :^o


Bäst att inte röra mer i detta. Det verkar ju vara rena lotteriet om inställningarna ska funka eller inte [-o<
Användarvisningsbild
Str@tocaster
Geocachare
Inlägg:319
Blev medlem:tis nov 25, 2008 14:21

Inlägg av Str@tocaster » fre maj 15, 2009 7:43

Jag såg att det nyss kommit en ny version av GSAK (7.2.5.27) som jag inte installerat. Kan det vara den som gjorde att camdan lyckades få allt att funka? Glad i hågen hämtade jag hem den och installerade. Spänningen var oliiiiiiidlig när jag fört över datat till GPS:en. Skulle jag kunna hitta Ödehuset :?:

Nix, hos mig blev det dehuset i stället.

Instämmer med camdans teori om lotteri :cry:
Bild
Oregon 450T med Friluftskartan Pro (SGSIII och c:geo för spontancaching)
Användarvisningsbild
Str@tocaster
Geocachare
Inlägg:319
Blev medlem:tis nov 25, 2008 14:21

Inlägg av Str@tocaster » ons maj 20, 2009 7:36

Korkat nog så försökte jag framhärda om att få en lösning på problemet. Denna gång försökte jag genom GPSBabels mailinglista och fick minsann svar på tal :shock:
Hi!

I use GSAK to send geocaching waypoints to my Garmin eTrex Legend HCx. My problem is that some characters (åäöÅÄÖ used in Sweden) disappears from the cache name (%smart function) when the cache name starts with one of these characters. The problem is extensively described in GSAK forum http://gsak.net/board/index.php?showtop ... 5&st=0&hl= and I am convinced that the problem appears in GPSBabel since the cache names are ok in GSAK before I send them to my GPSr. Now, the thread seems to have died and I am still stuck with the problem.
The thread died because it was answered, even including a citation from Garmin's own specs. Those characters are not supported in the Garmin protocol. We make best efforts to support additional characters when we can, but it's just not possible in all cases. We investigated as best we could but the unit just doesn't seem to support it. Going to Garmin about it is likely fruitless because the units aren't *documented* to support it.
Det verkar inte vara någon idé att driva detta vidare tyvärr :(
Bild
Oregon 450T med Friluftskartan Pro (SGSIII och c:geo för spontancaching)
Skriv svar